devolo dLAN 200 AV Starter Kit

After moving into our new home Silke and I were facing the usual network wiring problem:

  1. The master telephone socket is in the hall downstairs. The study with all the computers is upstairs.
  2. The interior phone cables are not really inspiring confidence.
  3. There is no phone socket in the study anyway.

The initial solution for this dilemma was creative use of long ethernet cables and a lot of adhesive tape. 🙂

After careful consideration I ruled out WLAN because of its reliability problems and lack of speed (ADSL2+ will max out 802.11g). Don’t get me wrong, WLAN is very nice to have. Silke and I use it for our laptop and Nintendo Wii. I just don’t want to depend on it for the Internet connection of my server.

I decided to give PLC a try. After browsing the offerings at the local PC World store I decided to buy the devolo dLAN 200 AV Starter Kit. My wife prefered the Netgear kit because of the nicer design of the included adapters. But it required Windows XP for configuration and didn’t specify the supported encryption algorithm. The devolo kit on the other hand promised full Mac OS X (and Linux) support and AES 128bit encryption.

Back at home I tried the dLAN adapters out. I plugged in one downstairs in the hall and one upstairs in the study. Within seconds they established a connection (indicated by a light on the unit). After that I removed the direct ethernet connection, connected the adapter upstairs to the switch in the study and the one downstairs to the router. A quick test confirmed that my computers could still access the Internet. It took only two minutes to get PLC working and I was very pleased.

Configuring the encryption took a bit longer. devolo had indeed included an easy to use configuration tool for Mac OS X. It did however not work for me at first: it asked for my password twice and didn’t find any dLAN adaptors afterwards. Finally I tried to run it using a local administrator account instead of my LDAP account. And that fixed the problem. The software found the adapter on the ethernet upstairs, allowed me to enter the security id of the adapter downstairs and configured encryption using a password I supplied.

The PLC setup is working without any problems since then. The round trip times (4.5ms on average) are not as good as hoped for. But throughput (5.5MByte/s) and reliability are very satisfactory.